梅开二度,亦无一度好
欢迎光临一度好
更多>> Java程序设计
build path指定执行环境javase-1.8 工作区中没有安装与此环境严格兼容的JRE
来源:一度好    发布时间:2019-07-26 11:00:12    访问量:103
内容简介 警告信息如下:Build path specifies execution environment JavaSE-1.8. There are no JREs installed in the workspace that are strictly compatible with this environment.

一、具体问题

1、在工程名的图标上有个黄色叹的图标,如图所示:

101.jpg

2、点开Problems,发现具体的警告信息内容如下:

Build path specifies execution environment JavaSE-1.8. There are no JREs installed in the workspace that are strictly compatible with this environment.

意思是说build path指定执行环境javase-1.8。工作区中没有安装与此环境严格兼容的JRE。

如图所示:

102.jpg

3、自己安装使用的JDK版本号为JDK12


二、解决方案

1、右键点击工程项目图标 demo,选择弹出菜单的最底部的“Perproties”

2、在弹出的窗口中点击“Java Build Path”,在右侧的窗口中,点击“Libraries”

选中“JRE System Library [JavaSE-1.8]”,点击“Remove”按钮,如图所示:

201.jpg

3、选中“Modulepath”,点击“Add Library”,如图所示:

202.jpg

4、在弹出的窗口中,选择“JRE System Library”,点击“Next”按钮,如图所示:

203.jpg

5、在弹出的窗口中,会看到,已经默认定位到你所安装的版本jdk-12上面了,直接点击“Finish”按钮,如图所示:

204.jpg

6、点击“Apply”,点击“Apply and Close”

7、警告信息消失,问题解决


(编辑:一度好)
下一篇: 没有了
发表评论
昵 称: *
邮 箱: *
公 开:  
验证码: * captcha 看不清?点击换一张
点击排行榜
首页 / 设为主页 / 加入收藏 / 关于本站 / 友情链接 / WAP版