梅开二度,亦无一度好
欢迎光临一度好
更多>> PHP程序设计

Windows环境下根据PHP的phpinfo信息下载安装对应memcache版本

来源:一度好    发布时间:2018-11-28 17:08:05    访问量:810
内容简介 在Windows下的PHP环境中,想要安装memcache,需要注意的事项,如何选择正确的版本。

  1、在你的php环境部署完成后,接下来就要考虑安装memcache了。

  2、获取php相应的配置信息,用以选择下载相应的memcache版本。

  在 phpinfo(); 的返回信息中:

  (1)获取php的版本号:PHP Version 5.6.27,说明是php5.6版本

  (2)判断是x86环境还是x64环境

  Architecture: x86 ,说明你需要下载x86环境的。

  特别说明:这与你电脑的操作系统没有关系,即使你的电脑显示的是64位操作系统,如果Architecture的值是x86,你也只能下载x86,而不能下载x64的,切记。

  (3)判断VC的版本号

  Compiler: MSVC11 (Visual C++ 2012) ,说明你需要下载VC11版本的。

  (4)判断是ts还是nts

  Thread Safety: disabled ,说明你需要下载nts版本的,如果值为 enabled,则需要下载ts版本的。

  备注:Thread Safe(线程安全)版本,None Thread Safe(非线程安全)版本。

  相应的也可根据下面2项值来进行判断:

  Zend Extension Build: API220131226,NTS,VC11

  PHP Extension Build: API20131226,NTS,VC11

  说明需要下载nts-vc11版本的。

  总结:根据返回的结果,你需要下载对应的版本为:5.6-nts-vc11-x86

  3、在php.net官网上,下载memcache

  (1)打开如下的网址:https://windows.php.net/downloads/pecl/releases

  (2)找到memcache,点击进去,会出现版本号页面,再点击进去

  (3)根据第2步总结的结果,下载对应的版本

  即:php_memcache-3.0.8-5.6-nts-vc11-x86.zip

  4、安装memcache

  把下载包解压到本地后,把php_memcache.dll文件,复制到php对应的版本下的 ext 目录中,如:php-5.6.27-nts\ext下

  然后,在 php.ini上增加一行:

  extension=php_memcache.dll

  5、重启服务器,安装完成

  6、检测安装结果

  在phpinfo();页面,搜索memcache,即可看到memcache已经启用了。

(编辑:一度好)
标签: windows | php | phpinfo | memcache
评论列表
暂时没有相关记录
发表评论
昵 称: *
邮 箱: *
验证码: * captcha 看不清?点击换一张
点击排行榜
首页 / 设为主页 / 加入收藏 / 关于本站 / 友情链接 / WAP版